WEB-O-RAMA VERSION HISTORY

Notes

All-new Web-O-Rama Professional 8 Available on CD

Web-O-Rama Professional 8 is now available. The new version includes a custom editing-window interface that features as-you-type syntax coloring, optional line numbers, unlimited undo/redo, a Web View tab that allows you to switch instantly between your HTML code and a code preview window, and much more. Additional information, along with screen shots, is available on The Computer Guys’ Web site at www.kevingunn.com. Use the order form (order.doc, included in the program folder) and send $35.00 to Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933, to receive a copy on CD. Please let me know by e-mail (compguys@eudoramail.com) that you have mailed a request so I will know to check my post-office box.

Web-O-Rama Pro Classic Available on CD

Web-O-Rama Pro Classic (formerly Web-O-Rama Professional) features the classic look of Web-O-Rama and includes a Web View tab that allows you to switch instantly between your HTML code and a code preview window. Screen shots are available on my Web site at www.kevingunn.com. Use the order form (order.doc, included in the program folder) and send $29.00 to Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933, to receive Web-O-Rama Pro Classic on CD. Please let me know by e-mail (compguys@eudoramail.com) that you have mailed a request so I will know to check my post-office box. For $21.00, I will e-mail you the zipped weborama.exe file. The stand-alone weborama.exe file requires the latest full version of Web-O-Rama Standard and Internet Explorer 5 or higher to work properly.

Upgrades

There is no upgrade charge for people who have purchased earlier versions of Web-O-Rama Professional. For $6.00, which covers the cost of the CD, mailer, and postage, I will send you the latest version on CD. Please use the order form (order.doc, included in the program folder) to request a new copy of Web-O-Rama Professional.

Web-O-Rama Standard Now Available on Floppy Disks or CD

If you are having trouble downloading Web-O-Rama Standard from my Web site (www.kevingunn.com) and would like a copy of the latest version of Web-O-Rama Standard on floppy disks or CD, send $9.00 for floppies or $19.00 for a CD to Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933. Checks and money orders (including international money orders) accepted.

Help Keep Web-O-Rama Free

If users in a financial position to do so would consider making modest donations to help with programming costs, I can continue to offer Web-O-Rama Standard as donationware rather than traditional shareware (timed or limited to a certain number of uses without a registration key). Unfortunately, donations have been so sparse that it is doubtful I can keep offering Web-O-Rama Standard on the honor system. Programming takes both time and money, neither of which I seem to have enough of these days. If you find the program useful, please consider making a small donation. I would be grateful. My mailing address is Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933. Even $1 would help. International money orders are more than welcome from overseas users. If you send a donation, please e-mail me at compguys@eudoramail.com and let me know. Because I do not get many donations, I do not check my post-office box very often.

Updates

Please check my Web site at www.kevingunn.com for product updates. Download the latest version (check for beta versions, too) before reporting bugs. New versions are posted frequently. If, for some reason, the site is unavailable, you can e-mail me at compguys@eudoramail.com or send a hard-copy letter to Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933.

Important Installation Notes

Please read install.doc before installing this program! There is important installation information contained in it.

Changes

Summary of Changes in v. 8 (Web-O-Rama Professional)

The new Web-O-Rama Professional includes a custom editing-window interface that features as-you-type syntax coloring, optional line numbers, unlimited undo/redo, and much more. There is no Standard version. Version 8 is available on CD. An order form (order.doc) is included in the program folder. Use the order form and send $35.00 to Kevin Gunn, P.O. Box 442155, Lawrence  KS  66044-8933. You can also contact me at compguys@eudoramail.com or visit my Web site at www.kevingunn.com for further details.

Summary of Changes in v. 7.92 (Web-O-Rama Pro Classic)

· Clarified the relative path feature on Body, Image, Links, Rules, and Sound dialogs by rearranging elements.

· Updated documentation.

· Miscellaneous code improvements..

Summary of Changes in v. 7.91 (Web-O-Rama Pro Classic)

· Updated documentation, including Help file.

· Added Save Settings options to addition dialogs.

Summary of Changes in v. 7.9 (Web-O-Rama Pro Classic)

· Updated documentation, including Help file.

· Miscellaneous code improvements.

Summary of Changes in v. 7.87

· “Remember Body Attributes” added to Body dialog.

· “Remember Font Attributes and Additional Fonts” added to Fonts dialog.

· “Remember Border and Spacing Options” added to Image dialog.

· “Remember Table Style Options” added to Table dialog.

· Web-O-Rama Professional renamed Web-O-Rama Pro Classic in preparation for release of Web-O-Rama Professional 8, which features a completely different editing window.

· Additional improvements.

Summary of Changes in v. 7.83

· Improved Help file.

· Options for Cell Height and Cell Width added to Table dialog. Cancel button added to Auto-Table tab.

· Minor bugs fixed.

Summary of Changes in v. 7.8

· Improved file handling for saving files to and opening files from servers.

· Improved error handling.

· Eliminated annoying “flash” when saving or opening multiple files.

Summary of Changes in v. 7.75

· Service Pack 5 for Visual Basic installed. SP5 fixes various Visual Basic issues.

· Miscellaneous code improvements.

Summary of Changes in v. 7.73

· Relative paths will now calculate correctly if inserted image files, sound files, or links are higher in the project folder structure than the HTML document being edited. Absolute paths are used if image files, sound files, or links are outside the path of the project folder. A red “light” will display to the right of the “Use Path” text box if the relative path cannot be determined. A green “light” will display if the relative path can be calculated.

· Simplification of dialogs (Body, Frames, Image, Links, Rules, and Sound) on which relative paths to image files, sound files, or links are calculated.

· Glitch in Sound dialog fixed. Under some circumstances, after selecting a sound file or after canceling a “Find Sound” or “Browse,” the dialog was not refreshing correctly and some of the controls on the dialog would no longer be visible.

· Updates to Help file.

Summary of Changes in v. 7.67

· “Insert” >“File” on the main menu now tracks the eight most recently inserted files. This will benefit people who create templates.

· Revised User Buttons dialog to allow multi-line entries with carriage returns.

· Made major changes to the Links dialog. The Links dialog now has two tabs, Standard Link and Named Anchor.
· Made major changes to the Lists dialog. The Lists dialog now has two tabs, Standard List and Definition List. Additional list options have also been added (similar to the new options on the Table dialog).

· Added ability to copy or move folders from the Copy Files dialog. Renamed Copy Files dialog to Copy Files or Folders dialog.

· Redesigned Table dialog. Table dialog now has an Auto-Table tab. This tab allows the creation of formatted tables containing empty cells. Use caution when tables with large numbers of rows and cells.

· Added “Edit Read-only File…” and “Save File as Read-only…” to the “File” menu. Editing a read-only file removes the read-only attributes. To re-apply the read-only attributes, choose “Save as Read-only…” from the “File” menu.

· File View can now be resized by placing the mouse cursor to the right of the File View tabs and dragging the window to the left or right.

· If Web-O-Rama generates an error, some of the error messages will now be accompanied by an error number and an error description. This will be helpful to me in troubleshooting bug reports.

· Links dialog made more consistent with other dialogs using the relative path feature.

· Added a Links button to the Editing Buttons toolbar. Multiple links can be selected simultaneously. Relative path to links is determined based on default project (see Project Maintenance dialog).

· “On top” feature now puts dialogs on top of Web-O-Rama only. Other programs (if you open Notepad, for example) can appear on top of Web-O-Rama dialogs. Thanks to Carlos Yoshinobu Une, a programmer in Brazil, for pointing out the problem (he also suggested improvements to v. 6.50).

· If a dialog is not in the on-top position, the dialog will appear in the Windows Taskbar. If it is on top, the dialog will not appear in the Taskbar. Previously, dialogs did not appear in the Taskbar at all. Although this was by design, having dialogs show in the Taskbar seemed preferable.

· Inserting a link from the “Insert” menu now determines the relative path to the link based on the default project folder.
· Inserting “Quote Mark” from the “Insert” menu now inserts a pair of quote marks.

· There is now an option on the Preferences dialog to show the file name only or the full path and file name on the main editing window tab (Web-O-Rama Professional only).

· Added Project Folder Maintenance dialog, which can be accessed from the new “Projects” menu item. The “Root Folder” concept for establishing relative paths to images, links, and sound files was never particularly intuitive. I changed the “Root Folder” terminology to “Project Folder” throughout and created a Project Folder Maintenance dialog that allows the user to select up to eight project folders. The default project folder can be changed “on the fly” from the “Projects” menu. Selected project folders appear on the Project Folder drop-down list on the dialogs with the relative path feature (Body, Frames, Image, Links, Rules, and Sound dialogs). The default project folder appears automatically as the selected item in the drop-down list. Thanks to Will Copeland, from Belfast, Ireland, for working tirelessly to help me implement this feature, which came about through a lengthy e-mail exchange.

· Removed the option to browse for and set a default folder for program startup on the Preferences dialog. This has been rendered obsolete by the Project Maintenance feature. The Preferences dialog now shows the currently selected Default Project Folder, with an option to open files in this folder at program startup. The Project Maintenance Dialog can also be accessed from the Preferences dialog in order to change the default project folder.

· Character tab on File View fixed so it does not go into “rename” mode when a character is clicked on more than once.

· Redrew some of the icons on the Editing Buttons toolbar to make them more intuitive.

· Fixed a bug (the bug existed in Web-O-Rama Professional only) that caused the program to lock up if multiple files were open and a file was selected from the “Windows” ( “More Windows…” menu.

· Sound dialog redesigned to eliminate the necessity of having two tabs on the dialog.

· Copy Files dialog made larger. 600 ( 800 screen resolution is strongly recommended.

· Added option to Preferences dialog (Colors and Styles tab) to Use Uppercase Tags or Use Lowercase Tags throughout. This does not affect user-defined tags on the User Buttons dialog.

· Updated Help file.

· Added www.kevingunn.com to the “Help” menu. Clicking on the link from the “Help” menu takes you directly to my site, where you may browse News, Bugs, etc., for the latest information about Web-O-Rama.
· Added About box, available from the “Help” menu.

· Fixed several minor incompatibilities between Web-O-Rama and Windows 2000.
Summary of Changes in v. 7.36

· Added option for custom meta tags to the Meta dialog.

· Added third tab to Table dialog, Table Text, to make the Table dialog a little roomier.

· Service Pack 4 for Microsoft Visual Studio installed. The Service Pack updated system files used by Visual Basic 6. Bug fixes and performance enhancements were included. This may take care of some of the rare bug reports I have received about Web-O-Rama.
· Cosmetic interface improvements so that interface is consistent whether system “Large Fonts” or “Small Fonts” are being used. The default font throughout the program is now 8-point MS Sans Serif (10-point MS Sans Serif on the buttons at the bottoms of the dialogs) rather than 9-point Arial. This has made it possible to reduce the size of some of the dialogs slightly without sacrificing readability. I originally programmed Web-O-Rama using system “Large Fonts.” When I switched to “Small Fonts” (the default), visual oddities of which I had been unaware became evident.

· Updated Help file.

· Splash Screen now shows properly aligned text no matter what screen resolution or system font size has been selected.

· Added additional file types to certain “Open File” dialogs.

· Added option to turn off “Word Wrap” (the first item under the “Text” menu). This was added by request and may come in particularly handy for people working extensively with JavaScript.

· Word wrap can now be enabled or disabled, from the Preferences dialog, in the main text boxes on the Form, List, Page Creator, Style Sheet, and Table dialogs. This should make them easier to use.

· Streamlined much of the internal code.

· Enabling “Use Non-dithered Colors” in Preferences has always brought up the Hex Value dialog when colors were selected on other dialogs (such as “Text Color” on the Body dialog) rather than the default Windows Color dialog. In previous versions, exiting the Hex Value dialog without selecting a color did not return you to the original dialog (such as the Body dialog). Exiting the Hex Value dialog now returns you to the original dialog. This applies to some of the other dialogs, as well.

Summary of Changes in v. 7.20

· Added Web-O-Rama Help file.

· Improved consistency among dialogs.

· Changed graphic on “Copy to Clipboard” button. It is now white when it is not enabled and red when it is enabled, just as the “On Top” button.

· “Copy to Clipboard” button now remembers its last state (on or off).

· Fixed compatibility problem with Internet Explorer 5.5 (Web-O-Rama Professional).

· Miscellaneous improvements to code.

· If you are using the Page Creator dialog and are on the Template tab, clicking “OK” will add the template on the Template tab to the HTML document, rather than the information from the Page Attributes dialog.

Summary of Changes in v. 7.05

· Under some circumstances, if a dialog were in the on top position and a message box popped up, the message box could appear behind the dialog, making the message box difficult to close and making it impossible to continue working normally. This has been fixed and should no longer cause problems.

· New, improved splash screen!

· On some of the dialogs (Body, Image, Links, Rules, and Sound), there is a feature to use the relative path to graphics, files, and sounds. I have tried to make this more intuitive and consistent. The new implementation should be easier to use. You can “Set Root Folder…” on the Preferences dialog and toggle “Use Root Folder…” on and off. The root folder should be the main folder containing the Web pages you are working on. If your main folder is mysite, your images are in subfolder images, and you add an image called mygif.gif to your Web page using the relative path feature, the HTML code will interpret the path as images/mygif.gif (<IMG SRC=“images/mygif.gif”>). This feature becomes more comprehensible with use. In addition, there is a check box on each of the dialogs that utilize the relative path to set “Name” as the default; otherwise, “Path” will be used.

· Added a “Copy [Image or Sound] to Selected Folder” button to the dialogs that use the relative path feature. This replaces the check box that performed a similar but less intuitive function.

· Three Help files, for HTML 3.2, HTML 4.0, and style sheets, have been added, courtesy of (and used with permission of) the Web Design Group. Please note that the inclusion of these Help files does not add anything to the cost of Web-O-Rama, and that the help files are freely available at the Web Design Group’s Web site (http://www.htmlhelp.com).

· Web-O-Rama now supports drag and drop. Single or multiple files can be dragged from Windows Explorer to Web-O-Rama, where they will open normally. Files cannot be dropped onto Web-O-Rama’s editing window because this feature would disable internal text drag and drop. You can drop files beside the editing window if the editing window is not maximized, or anywhere on Web-O-Rama if all files are closed. If you have created an icon for Web-O-Rama on your desktop, you can drag files onto the icon to start Web-O-Rama and open the files.

· A new tab, “Color Chart,” added to the Hex Value dialog. This is a visual representation of the 216 “Web-safe” (non-dithered) colors. Pausing the mouse cursor over a color will display the hex value. Clicking a color will return you to the first tab, where you can save the color or add it to your HTML document.

· Much improved “Quick View” on Image dialog.

· Minimizing Web-O-Rama will close any open forms so they are not visible once the main Web-O-Rama screen minimizes.

· Option to “Remove HTML Tags from Text” added under main “Text” menu item.

· More efficient code implemented for some of the dialogs. The dialogs that access fonts now load much faster.

· Additional font drop-down lists added to Body and Font dialogs, allowing the selection of multiple fonts.

· A “Close file” button added to the toolbar immediately to the right of the “Open file” button.

· Removed option to use Microsoft Word as an external spell checker. This had never worked very well and was causing problems on computers without Word. A built-in spell checker will be included in future versions of Web-O-Rama. Users with Word can paste HTML files from Web-O-Rama into Word, spell-check them, then paste them back. That is all the Word function was doing.

· There is now a “Copy to Clipboard” feature. I have added buttons, to the right of the “OK” button on the dialogs, that will copy the dialog data to the clipboard, when “OK” is pressed, so the data can be copied to other HTML documents. If the “Copy to Clipboard” button is blue and gray, the feature is disabled. If it is blue and white, “Copy to Clipboard” is enabled.

· Removed Calendar dialog. A calendar is now accessible on the Character dialog.

Summary of Changes in v. 6.89

· Added “Quick View” tab to Image dialog. This allows fast previewing of graphics files.

· Due to some goofy coding, the Links dialog was not working correctly. It has been fixed.

· Problem with Metaname dialog fixed. I do not know if this was a problem in 6.71 or not.

· Added “HTML Document Type Declaration (DTD) Style” to Preferences dialog. This setting can affect the way browsers interpret the HTML code. Inexperienced users should leave this selection at the default setting (“HTML 3.2”) or change to “HTML 4.0 Transitional.” 

· Some terminology changes to the interface. “Directories” are now referred to as “Folders” throughout.

· Added a Page Creator dialog, accessible under the “Insert” menu (“Start Page Creator…”). This allows users to quickly build a Web page using TITLE, META, and BODY attributes. Easy access to the Meta and Body dialogs from the Page Creator. Option to save the template as a file, which can then be easily inserted into HTML pages using “Insert” > “File…”.

· A Web-O-Rama user pointed out to me that Internet Explorer and Netscape use different BODY parameters for margins. Utter foolishness! I changed the Body dialog to reflect this … there is now a “Margins” tab. It is possible to include margin settings for both Internet Explorer and Netscape simultaneously, although I have not tested this with Internet Explorer 3.X or Netscape 3.X or lower.

· An “Include Template” checkbox added to the Body dialog. Checking this box will frame the BODY attributes with a standard set of HTML tags.

· Fixed minor glitch in “Insert” ( “File” operation.

· Improved ability of Sound dialog to stop playing selected sounds. 

· Miscellaneous improvements and minor bug fixes.

Summary of Changes in v. 6.71

· A File View tab has been added to the main editing window. File View can be toggled on or off (under the “View” menu item). The first tab, Files, shows the current directory and file list. Clicking on a file opens it (if it is not already open) or brings it to the front (if it is currently open). Selecting an image file opens the Image dialog. The second tab, Tags, is a tree of the most commonly used tags. Selecting Insert will insert the tag (without parameters) when the tag is clicked. Selecting View will open the Tag List dialog with the selected tag highlighted and a description provided. The tag can then be inserted from the Tag List dialog, if desired. The Characters tab is a tree of keyboard, special, and accented characters (I found that I needed this feature even though it duplicates much of the Characters dialog). Clicking on one of the characters adds it to the document.

· The Frames dialog has been completely rewritten to be more user-friendly and versatile. Some very cool features.

· The Links dialog has been redesigned to be much more intuitive.

· Many of the other dialogs have been redesigned to be more compact.

· The Hex Value dialog has an interesting new feature … an Image Color tab. Select an image and move the mouse over it. The little box between “Find Image” and “Use Color” will change color to match the color of the image under the mouse pointer. Clicking on the image will add the color value to the “Values” box. Clicking on “Use Color” will snap you back to the first tab with the selected color value added. It can then be inserted into the document. The “Match Safe” button will snap you to the first tab with the closest “safe color” match to the selected image color value (since there are only 216 “safe” colors, the match may not be terribly close). I have found this extremely useful in creating “color coordinated” Web pages.

· I got rid of all the “Export Data” tabs and drop-down lists. These were utilized by the program itself and were not actually a user feature. This saved some space and I think it made the program less confusing.

· Many miscellaneous improvements to the code and program interface.

Summary of Changes in v. 6.50

· Many, many improvements to the code.

· The Horizontal Rule dialog has been put back in (there is a button on the dialog toolbar).

· The Recent Files and Recent Directories lists now show the most recently opened file or directory as the first item in the list. I had been meaning to fix the lists but had not found the time. A Visual Basic programmer in Brazil (Carlos Yoshinobu Une) sent me an e-mail containing some interesting and helpful code, including a more sophisticated method of implementing the lists. I was able to adapt it for inclusion in Web-O-Rama. Thanks, Carlos!

Summary of Changes in v. 6.33

· A Preferences dialog has been added. This simplifies Web-O-Rama’s menus and presents the preferences in a more easily understood manner. “Preferences” is on the main menu at the top of the program.

· Due to a minor coding error, some users may not have been able to set a Default Folder or open files from the Recent Files list. This has been fixed.

· A Copy File dialog has been added. Its operation is self-explanatory. I do not know how useful others will find this, but I frequently want to copy or move files without exiting or minimizing Web-O-Rama.
· A number of mostly minor bugs have been fixed.

· When selecting multiple files to open, if the combined length of all the file names exceeded 256 characters, an error occurred. This has been fixed.

· Canceling a print operation no longer generates an error.

· In some cases, selecting the “Autosave File” on some of the dialogs may have resulted in an error or a failure to save the file; this has been fixed. Other minor file-handling bugs have been fixed and in general all file handling has been enhanced.

· Using Microsoft Word to spell check documents now works, although you have to spell check the file in segments if the file exceeds 32 kilobytes in length.

· Cutting and pasting or copying and pasting occasionally resulted in the material showing up double-spaced. This has been fixed.

· File View and Directory View removed (see below).

· Additional user options (see the Preferences dialog).

· The image viewer on the Image dialog now “snaps” to the center of the image if the image is larger than the viewing area.

Summary of Changes in v. 6.0

· Interface improvements to all the dialogs.

· I installed Visual Basic 6 on August 29. VB6 improves the function of many of the controls, including the Rich Text Box, which comprises the main editing window. The Rich Text Box now prints “normally.” VB6 also compiles the code more efficiently, resulting in a smaller .exe file.

· You can now save custom colors using the Hex Value dialog.

· A Style Sheet dialog added. Although its operation is reasonably intuitive, an understanding of style sheets is necessary in order to use it. This dialog is still in development. User input would be appreciated.

· Major improvements to the Tag List dialog. A row of windows across the bottom displays the browsers and HTML version each tag and each attribute works with. Red indicates no support or partial support, green indicates full support. This information was painstakingly gathered from a variety of public-domain resources and represents the most recent available.

· Added a Splash Screen (can be toggled off under the “Options” menu) that appears when the program first starts.

· If you click on “Date” under the “Insert” menu a dialog opens showing a calendar. A drop-down list gives you a number of options.

· Major improvements to the interface, including code enhancements that result in smaller resource use..

· The following was removed starting with v. 6.15 due to insurmountable errors. A new implementation will be added to future versions. [A new Open-file View toolbar added. Clicking on it under the “View” menu opens a viewing window beneath and to the left of the toolbars that shows all currently open files on the first tab and drive / directory / files on the second tab. Clicking on a particular file name on the “Open Files” tab brings the file to the front. You can open files from the “Directories” tab. Can be toggled on and off.]

· Improvements to the dialogs. The Image dialog now has a drop-down list for “Alternate Text.” After selecting an image, this box will contain several “Alternate Text” options. I found that I liked having the image dimensions listed. If you do not want to use one of the options from the list, you can type one of your own. Default is “None.”

Summary of Changes in v. 5.03 

· “Unformat Text” option added under “Text” menu. If you are cutting and pasting from a Word document or other document that contains formatting for typeface, type size, etc., “Unformat Text” will remove the formatting.

· All of the option buttons replaced with “graphical style” push buttons. 

· “Spinner” controls added beside all the fill-in boxes that require numbers. I have been putting off doing this because it requires an additional .ocx and has entailed the release of a new full version in order to install the .ocx on users’ systems. It significantly enhances the program, however, and I felt it was worth it.

· You can now copy image and sound files from other places on your hard drive to the directory you are working in without having to exit Web-O-Rama. On the Body, Image, and Sound dialogs, there is an “Autosave” checkbox. Check it to have images and sounds saved to the selected directory. “Autosave” will not overwrite a file of the same name (you will have to do this manually).

· Option added (or “re-added,” under the “Options” menu) to have cursor “Always Between Inserted Tags” or “At End of Inserted Tags if Text Selected.” The purpose of this feature may not be immediately self-evident, but it is something I personally use. The first option is the default. The second option is particularly useful if you are inserting tags for the first time into a text file rather than creating an HTML file from scratch. 

· New “flat” toolbar style (optional) and several redrawn graphics.

· The option to “Color Tags as You Work” has been removed for now. It was not a very “smart” feature and it was easy for it to get stuck on the tag color. This has saved some space and has increased the program’s speed. There are some bugs in Visual Basic 5 that make a more efficient routine impossible (or at least painful). I am hoping the bugs are fixed in Visual Basic 6, which is due out at the beginning of September, 1998. Look for Web-O-Rama 6.X about mid-September.

· All screen fonts available on your computer are now “gathered” by Web-O-Rama when you start the program. Although the program may appear sluggish when loading (it takes about as long as it does when you use the normal Windows Font dialog . . . slower on some computers than others, depending on the number of fonts you have), you will be able to access the fonts from the various dialogs without “going out” to the Windows Font dialog. Selecting fonts (from the drop-down lists) is significantly faster from the dialogs! The font of the drop-down lists changes to the selected font. Do not freak if you select a symbol font and you can no longer read anything on the menu . . . just hit your “up arrow” or “down arrow” key to move to the next or previous font. The font changes only where there is no “font sample” box on the dialog.

· Several of the dialogs now have an option to “Include Relative Path to Image from Selected Directory” (drop-down list). If your images or sound files are in a subdirectory of your main HTML directory, selecting the main directory path will allow the images to display and the sounds to play when using “View in Browser.” If your subdirectory structure reflects the structure of your Web site, no path corrections will be necessary before uploading Web pages. This feature becomes more clear with use. If all your images and sounds are in the same directory as your HTML pages, however, it will not appear to do anything (paths are unnecessary in this situation).

· Several additional tags added to “Insert” menu, including such tags as <PRE> and <BLOCKQUOTE>.

· Many, many enhancements to the dialogs.

· Support for up to six user-defined browsers (suggestion from a designer . . . I did not realize anyone had more than two or three). When searching for browsers other than Internet Explorer or Netscape, remember to change the “type of file” drop-down at the bottom of the Windows Find dialog to “All files (*.*)” or you will be unable to see the .exe files! I have been fooled by this myself.

· Eight items now on the “Recent Files” list.

Summary of Changes in v. 4.70

· New image viewer on Image dialog, with scroll bars so you can see all parts of large images.

· Long “Options” menu broken into three: “Tags,” containing the tag coloring options, “Text,” containing the text options, and “Options,” containing the program options.

· Bug fixed that may have caused program error if accessing deleted or renamed files or directories.

Summary of Changes in v. 4.40

· Selected text can be made uppercase or lowercase (under “Options” menu).

· Status bar added with line count/total number of lines, total number of open files, caps lock, num lock, and insert on/off.

· An enhancement to the Character dialog allows you to replace many keyboard characters with HTML character codes.

· Find and Find and Replace have been rewritten to be more functional and consistent.  “Close All” added to “Edit” menu.

· A “Directories” menu shows the 8 most recently used directories and will open them (this has turned out to be an extremely convenient feature).

· A lot of improvements to the code, including better error-handling.

· When you “Save All” open files, the program returns you to file you were working on.

· It is now no longer possible to open more than one instance of a particular file.

· A button has been added for the alternate browser.

Summary of Changes in v. 4.0

· Fully NT-compatible.

· Multiple files can be selected, opened, and saved (“Save All” added to “Edit” menu).

· Replace dialog rewritten to include “Match Whole Word”; multiple-file search and replace, including Undo.

· All dialogs now “remember” their last position.

· Data can be imported and exported between dialogs.

· Template dialog added.

· Tags can be converted to upper- or lowercase.

· Hex Value dialog rewritten to include multiple color palettes (16 colors and “Web-safe” colors).

· Service Pack 3 fixed bug that prevented tags from coloring in files >32 kb.

· Additional user options.
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Complete Version History (Skipped Version Numbers Indicate Minor Changes)

Versions prior to v. 6.71 (Visual Basic 6, SP3) are unsupported and are not recommended!

3.46 (release version)

Full release version.
3.47 (beta)

Major improvements to Character dialog.

3.48 (beta)

Added option to have cursor back up so that it appears inside tags when tags are added. This is under the “Options” menu item (“Cursor Inside Tags”).

3.5 (beta)

Major changes to Tables and Forms dialogs.

3.54 (beta)

All dialogs now “remember” their last position and open in the same place they were left.

3.58 (beta)

Removed option to use background images on dialogs to help streamline program (there were a number of reasons for this). Made it possible to export data from dialogs to Define User Buttons dialog. Code optimization. Miscellaneous improvements and enhancements. Added Create Template dialog. Data can be imported from various dialogs to create user-defined templates.

3.59 (beta)

Improvements to interface. Combined Define User Buttons and User Buttons dialogs for more intuitive operation. Additional enhancements.

3.6 (beta)

Revamped interface. Put “Make Tags Uppercase” and “Make Tags Lowercase” back in. The routine now leaves the material between quote marks alone (thanks to Don of GreenGecko Software, who out of the blue offered me his help).

3.61 (beta)

Additional improvements to Create Template. Many additional enhancements.

3.62 (beta)

Removed captions from dialog menu buttons. The images are reasonably self-explanatory, and if you pause the mouse pointer over any of the buttons a Tool Tip will pop up explaining the button function. This allows more screen area for editing. You can also change both the back color and fore color of the text editing window. Removed the About box. Unnecessary at this point and just adding to the size of the program.

3.64 (beta)

Added option to start program with no open text window and option to start text window maximized or normally.

3.66 (beta)

Misc. fixes. Added centered and right-justified paragraph buttons to standard toolbar.

3.68 (beta)

Reduced number of user-defined buttons to 18 from 24. Fixed an odd glitch with the Frames and Form dialogs.

3.7 (beta)

Major changes to Create Template dialog. Major internal code changes. Misc.  fixes and enhancements.

3.71 (release version)

Compiled after installation of SP3, which fixes numerous problems with the Rich Text Box and other Visual Basic bugs. Includes major changes to the Character dialog and internal code enhancements. Visual Basic programmers should read the note at the top of this file before installing.

3.89 (beta)

Enhancements and improvements. Making tags uppercase or lowercase now skips over material between <!-- and -->.

3.93 (beta)

Added support for non-dithered “Web-safe” colors. Major enhancements to Hex Value dialog. Code optimization.

3.95 (beta)

Further enhancements to Hex Value dialog.

3.99 (beta)

Multiple files can be selected and opened simultaneously; “Save All” added to “Edit” menu (will save all open files). “Save All” does not work if you have newly created files that have not been saved once.

3.991 (beta)

Fix to multiple file open and save.
3.993 (beta)

Experimental multiple-file search and replace, including undo. PLEASE back up files before using this new feature. Not thoroughly tested.

3.994 (beta)

Multiple-file search and replace less buggy. Additional improvements.

3.999 (beta)

This version is NT-compatible! Fixed bug that caused a crash when using “Replace” under some circumstances. Added “Whole Word” to search criteria for “Replace.” Added About dialog back in.

4 (release version)

Full non-beta version.

4.04 (beta)

Added “Close All” to “Edit” menu. Added “Directories” menu item that lists recently used directories. Fixed but that prevented “Save All” from appearing on “Edit” menu under some circumstances.

4.09 (beta)

Changes to “Directories” menu item, including removal of “Clear Directories” (see “Clear Recent Files,” below). Fixed bug that caused program error if Default Directory were set to a directory on a Zip drive and then the directory was renamed or deleted. Removed “Clear Recent Files” from “Options” menu. There are only four things on the Recent Files list and the code involved to delete them was not worth the overhead.

4.12 (beta)

More internal improvements. Added “Clear Recent Files” and “Clear Directory List” back to the “Options” menu. I figured out a way to optimize the code.

4.14 (beta)

Fixed an odd problem. Opening a file would not change the directory the program was accessing, so trying to view a file in a browser would not always display images. This “error” crept into the betas after the release of v. 4.0.

4.16 (beta)

Find and Find and Replace have been rewritten. At present, you can no longer choose the search direction.

4.17 (beta)

Further improvements to Find and Find and Replace. They no longer “loop” from the end of the file back to the beginning. There is still no search direction option.

4.22 (beta)

Button added to toolbar for alternate browser. Program will no longer open multiple instances of the same file. Additional code improvements.

4.27 (beta)

Bugs (I hope) worked out of Find and Find and Replace. Keyboard characters can now be replaced with HTML character codes using the Character dialog.  Additional code improvements.

4.3 (beta)

Two instances of the same file can no longer be opened. Status bar added at bottom, showing line number/total lines, number of open files, caps lock, num lock, and insert status. Major improvements to the Character dialog replace feature. A major bug was eliminated. Previously, closing the program with one of the dialogs minimized rather than closed would generate an error. The “Undo Last” on the Find and Replace dialog has been disabled until I track down a problem with it.

4.31 (beta)

Problem with “Undo Last” has been fixed.

4.32 (beta)

Problem with “Undo Last” not fixed! The “Undo” buttons on the Find and Replace dialog have been removed. At present, there is no practical way to incorporate them while preserving the non-modal state of the dialog (a modal dialog requires that you complete your actions and close the dialog before being able to do anything to the text). “Tool Tips” added to many of the forms (this is in progress); moving the mouse cursor to a particular button will give you a brief description of the button’s purpose.

4.33 (beta)

More bugs fixed! “Make Selected Text Uppercase” and “Make Selected Text Lowercase” added under “Options” menu.

4.4 (release version)

More bugs fixed! “Make Selected Text Uppercase” and “Make Selected Text Lowercase” added.

4.42 (beta)

Fixed a bug that may have caused a program error if the Default Directory were set and the directory deleted or renamed, or may have caused program errors if trying to access deleted or renamed files. This always happens within 48 hours after a new full version is released!

4.44 (beta)

Automatic tag coloring as you type and an option to use colored tags when adding data from dialogs. Long “Options” menu broken into three: “Tags,” containing the tag coloring options, “Text,” containing the text options, and “Options,” containing the program options.

4.46 (beta)

Fixed bug causing program error when “Uncolor Tags” selected. Fixed “File Not Found” error (I think).

4.47 (beta)

Fixed yet another bug in the Replace dialog that could cause the last word replaced during a search (NOT a “Replace All”) to be duplicated. When using the “List” dialog, list items were being added in reverse order! Fixed in 4.47.

4.51 (beta)

New image viewer, with scrollbars, for Image dialog. Many additional enhancements!

4.54 (beta)

Fixed bugs in Image dialog (image viewer); additional enhancements.

4.56 (beta)

Many enhancements to the dialogs!

4.58 (beta)

“Use Subdirectory Path” checkbox added to Image dialog; additional enhancements.

4.59 (beta)

Fixes problem with spell checking; fixes problem with inserting files into other files; Image dialog rewritten; other bug fixes and enhancements.

4.66 (beta)

Removed Rules dialog to free up some space, removed option to use “Absolute Path” (pointless), added options to “Use Path to Subdirectory from HTML Directory” to Body, Image, and Sound dialogs, many improvements to dialogs, many internal enhancements.

4.67 (beta)

Fixed glitch with browser buttons.

4.68 (beta)

Enhancements to the List dialog. Additional enhancements.

4.7 (release version)

Additions to “Insert” menu. Additional enhancements.

4.72 (beta)

Improvements to “Add Path to Subdirectory from HTML Directory” feature. Image and sound files can now be copied from one directory to another from the Image and Sound dialogs.

4.75 (beta)

More improvements and interface enhancements. Body dialog redesigned. Web-O-Rama now supports up to six user-defined browsers.

4.78 (beta)

Improvements to interface. Improvements to Tag List dialog.

4.79 (beta)

Links dialog fixed so it is once again possible to add the link source “by hand.”

4.8 (beta)

Fixed some serious bugs associated with the Body, Image, Links, and Sound dialogs, which were generating errors. Hasty coding was to blame!

4.82 (beta)

Improvements to the Body, Image, Links, and Sound dialogs. Option buttons added so any of the text boxes can be used for the file data.

4.83 to 4.89 (betas)

Code enhancements.

4.90 (beta)

Made toolbar buttons flat and redesigned some of the button graphics. Code enhancements.

4.91 (beta)

Fixed slight problem with Image dialog image viewer. Code enhancements.

4.92 (beta)

Made raised toolbar buttons an option. Code enhancements.

4.94 (beta)

Two options for cursor position added under “Options” menu. Code enhancements.

4.95 (beta)

“List” button added to toolbar. Enhancements.

4.96 (beta)

Fixes several problems, including a bug in the Metaname dialog that could cause a crash. Other enhancements.

4.97 (beta)

There was a problem with the “Find Microsoft Word” menu item. It was not enabling the spell checking feature of the “Edit” menu. It has been fixed. Files larger than 32 kb, however, can only be checked in sections.

4.99 (beta)

All screen fonts available on your computer are now “gathered” by Web-O-Rama when you start the program. Although the program may appear sluggish when loading, you will be able to access the fonts from the various dialogs without “going out” to the Windows Font dialog. Selecting fonts (from drop-down lists) is significantly faster from the dialogs now! Removed option to color tags as you work. The code was clunky and slow. I intend to add it back in if Visual Basic 6 fixes some problems.

5 (beta)

“Spinner” controls added beside all text boxes that require numbers. Many enhancements and refinements.

5.03 (release version)

More improvements.

5.05 (beta)

“Tree View” added. This shows a list of currently open files. Clicking on a file will bring it to the front. This feature can be toggled on and off from the “View” menu. Cool.

5.07 (beta)

A third toolbar added with Font Face, Font Size, and Font Color drop-down lists. I found that I frequently wanted to change fonts quickly. Highlight a section of text and make a selection. You can only select one of the font attributes at a time. Use the Font dialog for adding multiple attributes.

5.09 (beta)

Improvements to some of the dialogs (Image dialog in particular). Code optimized.

5.11 (beta)

“Tree View” changed to “File View” (under the “View” menu) and is now the first tab on a left-aligned toolbar, providing a quick way to switch between open files. “Directories” is on the second tab and allows you to easily open files in the current, or any, directory. All toolbars can now be toggled on and off and their state will be “remembered.”

5.14 (beta)

Added “Save Color” panel to Hex Value dialog.

5.18 (final VB5 beta)

Improvements.

5.19 (beta)

Eliminated the Template dialog and added a Style Sheet dialog. Web-O-Rama has so many dialogs that Visual Basic sometimes locks up when I try to compile it. I had to remove something in order to add the Style Sheet dialog, and the Template dialog was the only one I could conscientiously remove. If you want templates, you can just create them as HTML files and save them.

Visual Basic 6 Installed

Please see install.doc for some Web-O-Rama installation concerns.

5.2 (beta)

For some reason, no one liked the Font toolbar, so I removed it. Code optimized. Visual Basic 6 controls have some new and interesting features. I am still experimenting.

5.24 (beta)

All the toolbars (including the status bar, which is across the bottom) can be toggled on and off. Their state is remembered.

5.25 (beta)

Major cosmetic improvements to the dialogs. Additional miscellaneous code enhancements.

5.27 (beta)

Splash Screen added (can be turned off under “Options”). Improvements to Style Sheet dialog. It is still not terribly intuitive, but will help those familiar with style sheets to construct them. A few of the Style Sheet options are not completely functional yet. Added a Date dialog (“Date” under the “Insert” menu).

5.3 (beta)

Tag List dialog completely rewritten. All tags for which I could find documentation are listed. Compatibility shown for both tags and attributes.

6 (release version)
Code cleaned up, miscellaneous enhancements and improvements.

6.02 (beta)

Two minor bugs fixed. Selecting an unavailable drive from the Directory View caused the program to crash. This has been fixed. Closing all open files, then opening File View and clicking on it would cause the program to crash. This has been fixed.

6.05 (beta)

Numerous file-handling glitches fixed. Canceling a print operation no longer generates an error. Copy File dialog added.

6.15 (beta)

The File View toolbar was removed. It had a fatal flaw that I spent many hours trying to debug. At some point during this process, I realized that I was not even sure it was possible to fix. I am trying to come up with a more effective and bug-free implementation. Selecting multiple files to open with combined file-name lengths greater than 256 characters no longer generates an error.

6.21 (beta)

Many minor bugs fixed. Code optimized.

6.32 (release version)
Preferences dialog added. Most of the user-configurable preferences are now on this dialog. Problems using Microsoft Word as a spell checker have been more or less fixed. Cutting and pasting or copying and pasting no longer results in double-spaced material.

Service Pack 1 for Visual Basic 6 Installed

Updates some of the system files but has no functional effect on Web-O-Rama.
6.33 (release version)
Fixes some potential installation problems. Additional minor updates. Changes to readme.doc and install.doc.

6.4 (beta)

Improvements to the Preferences dialog. Choices, such as font and background color, now affect all open documents rather than just the one being viewed (previously, documents had to be closed and reopened before some of the changes would take effect). Horizontal Rule dialog added (button on toolbar). Other improvements.

6.46 (beta)

Recent Files and Recent Directories lists rewritten to show most recently opened file as first item. Code enhancements.

6.5 (release version)

Code enhancements.

6.51 (beta)

Fixed slight bug in Tag List dialog; misc. additional small fixes.

6.59 (beta)

Files, Tags, and Characters tabs added to main editing window. New Hex Value “Image Color” feature. “Export Data” tabs eliminated. Completely new Frames dialog. Many other improvements.

6.61 (beta)

Redesigned Links and Copy Files dialogs. Other improvements.

6.67 (beta)

The “Copy File” feature on several of the dialogs has been redesigned to be more intuitive. Additional interface improvements.

Service Pack 3 for Visual Basic 6 Installed

Updates some of the system files but has no functional effect on Web-O-Rama.
6.71 (release version)

Many additional improvements and refinements. The installation of Web-O-Rama should not have the same kinds of potential problems as earlier versions, due to Microsoft’s Service Pack 3 update. Due to sparse donations, this may be the last free version.
6.75 (beta)

Page Creator dialog added (under the “Insert” menu item). “Margin” tab added to Body dialog. “Insert Template” checkbox added to Body dialog.

6.81 (beta)

Fixed problems with Links dialog. Additional improvements and fixes.

6.87 (beta)

“HTML Document Type Declaration (DTD) Style” added to Preferences dialog (inexperienced users can leave at default setting). “Quick View” tab added to Image dialog. Minor glitches fixed in Page Creator dialog (meta tags now go in correct place, others). Additional improvements and fixes, including improved ability of Sound dialog to shut off sound.

6.89 (release version)

Bug in Metaname dialog fixed. I also went through the code for the entire program line by line, cleaning out unnecessary and inconsistent code. I discovered and repaired some minor coding oddities that may or may not have affected the program.

6.91 (beta)

“Remove HTML Tags from Text” added under “Text” menu item. Improvements to “Quick View” on Image dialog. General menu improvements.

6.92 (beta)

Help files added. Bug fixed that under certain circumstances allowed message boxes to open behind dialogs that were in the “on top” state, making the message boxes difficult to close.

6.97 (beta)

Chart added to Hex Value dialog displaying the 216 “Web-safe” (non-dithered) colors.

6.99 (beta)

Miscellaneous improvements.

7.01 (beta)

File drag and drop implemented, new splash screen, “Copy to Clipboard” feature added to dialogs, more coherent relative path implementation, many other improvements.

7.05 (release version)

Removed option to use Microsoft Word as external spell checker. Many improvements.

7.07 (beta)

Buttons for “Copy to Clipboard” now white when inactive and red when active to match “on top” push-pin buttons. Misc. improvements.

7.08 (beta)

Fixed compatibility issue with Internet Explorer 5.5 (Web-O-Rama Professional).

7.10 (beta)

“Copy to Clipboard” button now remembers its last position (on or off).

7.13 (beta)

Miscellaneous improvements.

7.2 (release version)

Added Help file.

7.22 (beta)

Improvements to Metaname dialog. Additional file types added to certain “Open File” dialogs. Updates to Help file.

7.28 (beta)

Added option to turn off “Word Wrap” (the first item under the “Text” menu). This was added by request and may come in particularly handy for people working extensively with JavaScript. Streamlined much of the internal code. Enabling “Use Non-dithered Colors” in Preferences brings up the Hex Value dialog when colors are selected on other dialogs (such as “Text Color” on the Body dialog). In previous versions, exiting the Hex Value dialog without selecting a color did not return you to the original dialog (such as the Body dialog). Exiting the Hex Value dialog now returns you to the original dialog. This applies to some of the other dialogs, as well.

7.3 (beta)

Interface improvements.

Service Pack 4 for Visual Basic 6 Installed

Updated certain system files to improve performance and fix other issues.

7.31 (beta)

Compiled after Service Pack 4 installed.

7.34 (beta)

More improvements. Updates to Help file.

7.36 (release version)

Full release version.

7.39 (beta)

Added ability to resize File View by clicking on the vertical divider. Character tab on File View fixed so it does not go into “rename” mode when a character is clicked on more than once.

7.41 (beta)

Added option to Use Uppercase Tags or Use Lowercase Tags throughout to Preferences dialog (Colors and Styles tab). Miscellaneous improvements.

7.43 (beta)

Sound dialog redesigned. Miscellaneous improvements.

7.44 (beta)

Fixed several minor incompatibilities between Web-O-Rama and Windows 2000. See the readme.doc for information about remaining minor problems.

7.51 (beta)

Added Project Folder Maintenance dialog. Additional enhancements.

7.54 (beta)

Made Links dialog consistent with other dialogs using the relative path feature. Inserting quote marks from the “Insert” menu now inserts both a beginning and ending quote mark. Inserting a link from the “Insert” menu now determines the relative path to the link based on the default project folder.
7.67 (release version)

Many many changes. See Summary of Changes in 7.67 (above).

7.73 (release version)

Relative paths will now calculate correctly if inserted image files, sound files, or links are higher in the project folder structure than the HTML document being edited. Absolute paths are used if image files, sound files, or links are outside the path of the project folder. A red “light” will display to the right of the “Use Path” text box if the relative path cannot be determined. A green “light” will display if the relative path can be calculated. Simplification of dialogs (Body, Frames, Image, Links, Rules, and Sound) on which relative paths to image files, sound files, or links are calculated. Glitch in Sound dialog fixed. Under some circumstances, after selecting a sound file or after canceling a “Find Sound” or “Browse,” the dialog was not refreshing correctly and some of the controls on the dialog would no longer be visible. Updates to Help file.

Service Pack 5 for Visual Basic 6 Installed

Service Pack 5 fixes various issues in Visual Basic.

7.75 (release version)

Recompiled after installation of Service Pack 5. Miscellaneous code improvements.

7.8 (release version)

Improved error handling, particularly if saving files to or opening files from a server. Additional improvements to code.

7.83 (release version)

Improvements to Help file and Table dialog. Miscellaneous code improvements.

7.87 (release version)

Many of the dialogs now have the option to “remember” settings. Miscellaneous code improvements.

7.9 (release version)

Updated documentation and code enhancements.

7.91 (release version)

Updated documentation and code enhancements.

7.92 (release version)

Relative path feature clarified on the Body, Image, Links, Rules, and Sound dialogs.
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